Summit Treestands
Fletching contact?
Equipment
Contributors to this thread:
IdyllwildArcher 18-Jul-21
Bou'bound 18-Jul-21
TJS 18-Jul-21
Blood 18-Jul-21
x-man 18-Jul-21
Grey Ghost 18-Jul-21
MA-PAdeerslayer 18-Jul-21
Old Reb 18-Jul-21
APauls 18-Jul-21
Bowfreak 18-Jul-21
18-Jul-21
My main bow, the one I've used for years (Bowtech Invasion) just go some new stuff as it's been pretty beat up.

Replaced strings, rest, and site with the exact same Black Gold 5 pin site, QAD drop-away rest, and Winner's Choice string/cables.

I got this done in CA and when returned to me, was pretty well tuned with some tinkering at the shop. I got back to my place in CA and had to make a very minor adjustment to the rest and it was tuned perfectly, drilling bull's eyes consistently. I did have one misfire that I don't know what happened, but the arrow hit very low in the dirt - I chalked it up to a lapse in form.

Fast forward, I'm back in AK and the bow took 3 flights.

I shot it for the first time up here in AK today and every arrow was hitting perfectly for the first 10 or so arrows.

Then all the sudden, I had a loud noise at the shot, like there was some kind of contact and the arrow hit about 18 inches low, but not off left or right. I figured it was a bad arrow or something and it broke or the nock came off at the shot, but everything was fine.

I shot again and the same thing happened. I shot a 3rd time and the same thing happened - hitting 18 inches low, not off to the right or left at all.

Ideas? It must be the timing of the rest?

From: Bou'bound
18-Jul-21
Fletching contact alone does not make a loud noise. Arrow contact may. Almost like the arrow is not being cradled in the rest and it off to the risers side.

From: TJS
18-Jul-21
Sound may be from the QAD rest being ever so slightly out of time. Fletching could be snapping it down instead of it dropping on its own. A slight adjustment fixes that, if that's the case.

From: Blood
18-Jul-21
Put a lighted nock on and use your phone to video it in slow motion. Watch the video and go frame by frame. The lighted nock and slow mo shows ALOT.

From: x-man
18-Jul-21
Check your rest over carefully. Second, check the cable guard. Sometimes when/if the cable guard is loose, it will seem fine at rest but, when you draw the extra tension will pull it out of the correct location.

From: Grey Ghost
18-Jul-21
Perhaps your rest rope has slid up the cable and isn't pulling the rest all the way up?

I've also seen cracked limbs suddenly cause low hits.

Matt

18-Jul-21
Had a similar problem and timing string needed to be adjusted. Lipstick fletchings with also so contact on rest as I’m sure you know. The noise I had was arrow slamming the rest down.

From: Old Reb
18-Jul-21
Also sounds like arrow knocking the rest down to me. I had this happen to me before. Turned out to be the rest. My shop gave me a new rest and took care of the faulty one with QAD. You can also use aerosol spray foot powder on the vanes to show if there is rest contact. It wipes off easily.

From: APauls
18-Jul-21
Put on a whisker biscuit and get back to killin.

Sorry - I just had to! Lol

From: Bowfreak
18-Jul-21
My guess is you are shooting through the rest as something moved and it is not dropping fast enough. Either that or the brake mechanism could be screwed up.

  • Sitka Gear