Summit Treestands
Gaia GPS Problem
Equipment
Contributors to this thread:
Dagwood 31-Dec-19
Overland 31-Dec-19
Grasshopper 31-Dec-19
WapitiBob 31-Dec-19
AndrewGaiaGPS 31-Dec-19
Dagwood 31-Dec-19
midwest 31-Dec-19
From: Dagwood
31-Dec-19
Using Gaia on my lease. Have many waypoints marking scrapes, white oak flats, tree stands and such over 4 years time.

So last week I cannot get a satellite lock for several hours. The next day, I’m able to lock on and use it but all my waypoints and tracks are completely gone.

Any ideas or suggestions?

From: Overland
31-Dec-19
Try logging in online. Perhaps your waypoints will still be there. I use Gaia extensively (pretty much every day) and have never had that problem. The few issues I have had, their customer service has assisted me quickly.

Did you update to the latest version?

31-Dec-19
I had the same issue in September two days before I left to elk hunt. I had the free version so not much I could do.

From: WapitiBob
31-Dec-19
Just restore your data off your latest backup.

31-Dec-19
@dagwood can you send us an email at support@gaiagps.com so we can troubleshoot? It'd be great to be able to look at your account. Feel free to cc andrew@gaiagps.com too, and I'll look in on it.

From: Dagwood
31-Dec-19
Well, after logging on to my account on the web page, it all came back to my IPhone. Whew, so glad. I actually didn’t know my data was on a website I could log onto, or I had forgotten it, I’m not very techy when it comes to computers and the interweb.

From: midwest
31-Dec-19
As Bob alluded to....back up your data!

  • Sitka Gear